Before Downloading LightHouse II...


Do you own CP300 or CP450C sonar?

To ensure your sonar module continues to communicate with your display, you should ensure your sonar is on the required software version before downloading LightHouse II.

CP300 CP450
CP300 must be on
v4.03 or later
CP450C must be on
v4.03 or later
Details and Download Details and Download


NOTE - CP100 is part of the R11 update and will automatically update any CP100 present after the R11 update has been applied.

PROCEED TO LIGHTHOUSE II SOFTWARE DOWNLOAD >>